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Spreadsheet Link Product Description
Use MATLAB from Microsoft Excel

Spreadsheet Link connects Excel® spreadsheet software with the MATLAB® workspace, enabling you
to access the MATLAB environment from an Excel spreadsheet. With Spreadsheet Link software, you
can exchange data between MATLAB and Excel, taking advantage of the familiar Excel interface
while accessing the computational speed and visualization capabilities of MATLAB.

Key Features
• Data preprocessing, editing, and viewing in the familiar Excel environment
• Sophisticated analysis of Excel data using MATLAB and application toolboxes
• Delivery of Excel based applications, using MATLAB as a computational and graphics engine and

Excel as an interface
• Interactive selection of available functions using the MATLAB Function Wizard
• Visual interface for customization of all Spreadsheet Link preferences

1 Getting Started
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Installation

In this section...
“Product Installation” on page 1-3
“Supported Excel Versions” on page 1-3
“Files and Folders Created by the Installation” on page 1-3
“After You Upgrade the Spreadsheet Link Software” on page 1-4

To use Spreadsheet Link, you must install Microsoft Excel first, and then install Spreadsheet Link.
Ensure that you use the correct MATLAB version based on the supported version of Excel. After
Spreadsheet Link is installed on your computer, you must set up the Spreadsheet Link add-in in
Excel.

Product Installation
Install the Microsoft Excel product before you install the MATLAB and Spreadsheet Link software. To
install the Spreadsheet Link add-in, follow the instructions in the MATLAB installation
documentation. Select the Spreadsheet Link check box when choosing components to install.

Note If you have several versions of MATLAB installed on your computer, Spreadsheet Link uses the
version that you registered last.

To install the Spreadsheet Link add-in, you need administrator system privileges on the computer.
Contact your system administrator to enable these privileges.

Supported Excel Versions
Use the following table to determine the correct MATLAB version to install, based on the version of
Excel installed on your computer. Each row in the table matches the MATLAB version with the
supported versions of Excel.

MATLAB Version Excel Versions
R2016b and later 2019, 2016, 2013, 2010, 2007
R2013b 2013, 2010, 2007
R2010b 2010, 2007
R2007a 2007

Files and Folders Created by the Installation

Note The MATLAB root folder, matlabroot, is where MATLAB is installed on your system.

The Spreadsheet Link installation program creates a subfolder under matlabroot\toolbox\. The
exlink folder contains these files:

 Installation
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• excllink.xlam: The Spreadsheet Link add-in for Microsoft Excel
• ExliSamp.xls: Spreadsheet Link example files described in this documentation

After You Upgrade the Spreadsheet Link Software
If MATLAB and Spreadsheet Link are installed on your computer, to upgrade to a newer version:

1 Install the new version of MATLAB and Spreadsheet Link.
2 Start MATLAB and a Microsoft Excel session.
3 Configure the Spreadsheet Link software. For details, see “Add-In Setup” on page 1-5.
4 If you have existing workbooks with macros that use Spreadsheet Link, update references to

Spreadsheet Link in each workbook.

To update the references in an existing workbook in Microsoft Excel:

1 In a Microsoft Excel session, open the Visual Basic® Editor window by clicking Visual Basic on
the Developer tab. (If you do not find the Developer tab, see the Excel Help.)

2 In the left pane, select a module for which you want to update a reference.
3 From the main menu, select Tools > References.
4 In the References dialog box, select the SpreadsheetLink2007_2010 check box.
5 Click OK.

See Also

More About
• “Add-In Setup” on page 1-5

1 Getting Started
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Add-In Setup
In this section...
“Configure Microsoft Excel” on page 1-5
“Work with Excel Macros” on page 1-9
“Work with Microsoft Visual Basic Editor” on page 1-9

Configure Microsoft Excel
To enable the Spreadsheet Link add-in, start a Microsoft Excel session and follow these steps.

If you use Microsoft Excel 2007:

1

Click  the Microsoft Office button.
2 Click Excel Options. The Excel Options dialog box opens.

If you use Microsoft Excel 2010 and later versions:

1 Select File from the main menu.
2 Click Options. The Excel Options dialog box opens.

The next steps are the same for both versions:

1 Click Add-Ins.
2 From the Manage selection list, choose Excel Add-Ins.
3 Click Go. The Add-Ins dialog box opens.
4 Click Browse.
5 Select matlabroot\toolbox\exlink\excllink.xlam. (matlabroot returns the full path to

the folder where MATLAB is installed.)
6 Click Open. In the Add-Ins dialog box, the Spreadsheet Link for use with MATLAB and Excel

check box is selected.

 Add-In Setup
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7 Click OK to close the Add-Ins dialog box.
8 Click OK to close the Excel Options dialog box.

The Spreadsheet Link add-in loads now and with each subsequent Excel session.

The MATLAB Command Window button appears on the Microsoft Windows® taskbar.

The MATLAB group appears on the top right of the Home tab in your Excel worksheet.

1 Getting Started
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Spreadsheet Link is ready for use.

Right-click a cell to list the MATLAB options.

 Add-In Setup
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Note If the options are missing from the context menu and if the Trust Center dialog box has the
Require Application Add-ins to be signed by Trusted Publisher check box selected, then you
must click the Enable Content button for every session.

To check the settings in the Trust Center dialog box:

1 Click the Developer tab.
2 In the Code group, click the Macro Security button. The Trust Center dialog box opens.
3 Click Add-ins.

1 Getting Started
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Work with Excel Macros
To work with Excel macros, follow these steps to enable the Developer tab on the Excel ribbon.

If you use Microsoft Excel 2007:

1

Click  the Microsoft Office button.
2 Click Excel Options. The Excel Options dialog box opens.

If you use Microsoft Excel 2010 and later versions:

1 Click the File menu.
2 Click Options. The Excel Options dialog box opens.

The next steps are the same for both versions:

1 Click Customize Ribbon.
2 From the Main Tabs list, select Developer and click OK. The Excel ribbon displays the

Developer tab.
3 In the Code section of the Developer tab, click Macros. The Macro dialog box opens. Use this

dialog box to run existing macros, create macros, and edit and delete macros.

Work with Microsoft Visual Basic Editor
To enable Spreadsheet Link as a Reference in the Microsoft Visual Basic Editor:

1 Open a Visual Basic session. Click the Visual Basic button on the Developer tab, or press Alt
+F11.

Note For instructions about displaying the Developer tab, see Excel Help.
2 In the Visual Basic toolbar, select Tools > References.
3 In the References — VBA Project dialog box, select the SpreadsheetLink or

SpreadsheetLink2007_2010 check box.
4 Click OK.

See Also
matlabroot

More About
• “Installation” on page 1-3
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Setting Spreadsheet Link Preferences
In this section...
“Preferences Dialog Box” on page 1-10
“Preferences in Worksheet Cells” on page 1-10

To control how Spreadsheet Link and MATLAB behave when Spreadsheet Link starts MATLAB in
Microsoft Excel, you can set preferences with the Preferences dialog box or within individual
worksheet cells.

Preferences Dialog Box
1 Click Preferences in the MATLAB group. The MATLAB group appears to the top right of the

Home tab in your Excel worksheet.

2 Set your preferences by selecting check boxes and filling in the text boxes. For the MATLAB
program id, enter the MATLAB version as shown in the Windows registry. For the MATLAB
startup folder, enter the full path of the startup folder. Select Use MATLAB desktop to start
MATLAB in full desktop mode (only the Command Window opens by default).

Preferences in Worksheet Cells
To set a preference in a worksheet cell in Microsoft Excel, enter text that runs the corresponding
Spreadsheet Link function in the worksheet cell. For example, to set the MATLAB version in a
worksheet cell:

1 Getting Started
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1 Set the MATLAB version to 9.0, which corresponds to MATLAB R2016a, by entering this text.

=MLProgramId("9.0")

2 To run the function, press enter.

For details, see MLProgramId.

See Also
MLPutMatrix

More About
• “Worksheet Cell Errors” on page 3-2
• “Startup Errors” on page 3-11

 Setting Spreadsheet Link Preferences
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Start and Stop Spreadsheet Link and MATLAB
In this section...
“Start Spreadsheet Link and MATLAB Automatically” on page 1-12
“Start Spreadsheet Link and MATLAB Manually” on page 1-12
“Connect to an Already Running MATLAB Session” on page 1-12
“Specify the MATLAB Startup Folder” on page 1-13
“Stop Spreadsheet Link and MATLAB” on page 1-13

Start Spreadsheet Link and MATLAB Automatically
When installed and configured according to the instructions in “Add-In Setup” on page 1-5, the
Spreadsheet Link and MATLAB software automatically start when you start a Microsoft Excel session.

Start Spreadsheet Link and MATLAB Manually
1 Select Tools > Macro.

• In Excel 2007, click the View or Developer tab, and then click the Macros button.
• In Excel 2010, click the View menu and select Macros on the Excel toolstrip, and then click

View Macros.
2 Enter matlabinit into the Macro Name/Reference field.
3 Click Run. The MATLAB Command Window button appears on the Microsoft Windows taskbar.

Connect to an Already Running MATLAB Session
By default, Spreadsheet Link starts a new MATLAB session. Alternatively, it can connect to an already
running MATLAB session.

Note  If several versions of MATLAB are installed on your computer, Spreadsheet Link always uses
the last registered version. If you try to connect to an already running MATLAB session that is not the
last registered version, Spreadsheet Link starts a new MATLAB session. Spreadsheet Link does not
connect to the existing one. To change the last registered version, see “Startup Errors” on page 3-
11.

To connect a new Excel session to an already running MATLAB session:

1 In MATLAB, enter the following command:

enableservice('AutomationServer',true)

This command converts a running MATLAB session into an Automation server.
2 Start a new Excel session. It automatically connects to the running MATLAB session.

Alternatively, you can start MATLAB as an automation server from the beginning. To start MATLAB as
an automation server, use the automation command-line option:

1 Getting Started
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matlab -automation

This command does not start MATLAB in a full desktop mode. To do so, use the -desktop option:

matlab -automation -desktop

If you always use MATLAB as an automation server, modify the shortcut that you use to start
MATLAB:

1 Right-click your MATLAB shortcut icon. (You can use the icon on your desktop or in the Windows
Start menu.)

2 Select Properties.
3 Click the Shortcut tab.
4 Add -automation in the Target field. Remember to leave a space between matlab.exe and -

automation.
5 Click OK.

For details, see “Manually Create Automation Server”.

Specify the MATLAB Startup Folder
MATLAB starts in the MATLAB root folder and completes the initialization. After starting, MATLAB
changes to the Spreadsheet Link MATLAB startup folder. For details about specifying the startup
folder, see MLStartDir.

Stop Spreadsheet Link and MATLAB
If you started the Spreadsheet Link and MATLAB software from the Excel interface:

• To stop both the Spreadsheet Link and MATLAB software, close the Excel session as you normally
would.

• To stop the Spreadsheet Link and MATLAB software and leave the Excel session running, enter
the =MLClose() command into an Excel worksheet cell. You can use the MLOpen or matlabinit
function to restart the Spreadsheet Link and MATLAB sessions manually.

If you connected an Excel session to an existing MATLAB session, close Excel and MATLAB sessions
separately. Closing one session does not automatically close the other.

 Start and Stop Spreadsheet Link and MATLAB
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Create Diagonal Matrix Using Microsoft Excel Ribbon
This example shows how to execute Spreadsheet Link functions to export a named range in a
worksheet to MATLAB and create a diagonal matrix using the Microsoft Excel ribbon.

The MATLAB group on the Microsoft Excel ribbon contains commands for common Spreadsheet Link
functions. For the list of common functions, see “Executing Spreadsheet Link Functions” on page 1-
31.

This example assumes that MATLAB is running after Microsoft Excel opens. For starting MATLAB,
see “Start and Stop Spreadsheet Link and MATLAB” on page 1-12.

In a worksheet, enter the numbers 1 through 5 into the range of cells from A1 through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

On the Home tab of the Microsoft Excel ribbon, click the MATLAB group in the top-right corner.
Then, select Send named ranges to MATLAB. When you select this command, the software
executes MLPutRanges.

Microsoft Excel exports the named range testData into the MATLAB variable testData in the
MATLAB workspace.

1 Getting Started
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Select the MATLAB group option Run MATLAB Command. When you select this command,
Microsoft Excel displays a dialog box. Next, create a diagonal matrix. Use the diag function to
specify testData as the input argument and d as the output argument. Enter this MATLAB
command in the dialog box and click OK.

d = diag(testData)

The software executes the MLEvalString function. The MATLAB variable d appears in the MATLAB
workspace and contains a diagonal matrix.

Retrieve the diagonal matrix into the worksheet by selecting cell A3. Select the MATLAB group option
Get data from MATLAB. When you select this command, Microsoft Excel displays a dialog box.
Retrieve the diagonal matrix in d by entering d in the dialog box and clicking OK. The software
executes the MLGetMatrix function.

The diagonal matrix displays in cells A3 through E7.

See Also
MLEvalString | MLGetMatrix | MLPutRanges

More About
• “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
• “Create Diagonal Matrix Using Worksheet Cells” on page 1-19
• “Create Diagonal Matrix Using VBA Macro” on page 1-21
• “Executing Spreadsheet Link Functions” on page 1-31
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Create Diagonal Matrix Using Microsoft Excel Context Menu
This example shows how to execute Spreadsheet Link functions to export a named range in a
worksheet to MATLAB and create a diagonal matrix using the Microsoft Excel context menu.

The MATLAB group menu in the Microsoft Excel context menu contains commands for common
Spreadsheet Link functions. For the list of common functions, see “Executing Spreadsheet Link
Functions” on page 1-31.

This example assumes that MATLAB is running after Microsoft Excel opens. For details, see “Start
and Stop Spreadsheet Link and MATLAB” on page 1-12.

In a worksheet, enter the numbers 1 through 5 into the range of cells from A1 through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

To find the command that exports the named range to MATLAB, right-click another cell outside of the
named range in the worksheet. The Microsoft Excel context menu appears. To see the MATLAB group
menu, select MATLAB.

1 Getting Started
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Select Send named ranges to MATLAB. When you select this command, the software executes
MLPutRanges.

Microsoft Excel exports the named range testData into the MATLAB variable testData in the
MATLAB workspace.

 Create Diagonal Matrix Using Microsoft Excel Context Menu
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Select the MATLAB group option Run MATLAB Command. When you select this command,
Microsoft Excel displays a dialog box. Next, create a diagonal matrix. Use the diag function to
specify testData as the input argument and d as the output argument. Enter this MATLAB
command in the dialog box and click OK.

d = diag(testData)

The software executes the MLEvalString function. The MATLAB variable d appears in the MATLAB
workspace and contains a diagonal matrix.

Retrieve the diagonal matrix into the worksheet. First select cell A3, and then select the MATLAB
group option Get data from MATLAB > d. The software executes the MLGetMatrix function.

The diagonal matrix displays in cells A3 through E7.

See Also
MLEvalString | MLGetMatrix | MLPutRanges

More About
• “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
• “Create Diagonal Matrix Using Worksheet Cells” on page 1-19
• “Create Diagonal Matrix Using VBA Macro” on page 1-21
• “Executing Spreadsheet Link Functions” on page 1-31
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Create Diagonal Matrix Using Worksheet Cells
This example shows how to execute Spreadsheet Link functions to export a named range in the
worksheet to MATLAB and create a diagonal matrix using Microsoft Excel worksheet cells.

The example assumes that MATLAB is running after Microsoft Excel opens. For details, see “Start
and Stop Spreadsheet Link and MATLAB” on page 1-12.

In a worksheet, enter the numbers 1 through 5 into the range of cells from A1 through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

Enter the Spreadsheet Link function MLPutRanges directly into the worksheet cell as a worksheet
formula. Double-click cell A3. Enter this text.

=MLPutRanges()

Press Enter. Microsoft Excel exports the named range testData into the MATLAB variable
testData in the MATLAB workspace. After a Spreadsheet Link function successfully executes as a
worksheet formula, the cell contains the value 0. While the function executes, the cell shows the
entered formula.

Double-click cell A5. Next, create a diagonal matrix. Use the diag function to specify testData as
the input argument and d as the output argument. The Spreadsheet Link function MLEvalString
executes the MATLAB command. Enter this text.

=MLEvalString("d = diag(testData);")

Press Enter. MATLAB executes the diag function. The MATLAB variable d appears in the MATLAB
workspace and contains the diagonal matrix.

Double-click cell A7. Now retrieve the diagonal matrix into the worksheet using the Spreadsheet Link
function MLGetMatrix. Enter this text.
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=MLGetMatrix("d","A9")

The diagonal matrix displays in cell A9 through E13.

See Also
MLEvalString | MLGetMatrix | MLPutMatrix | MLPutRanges

More About
• “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
• “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
• “Create Diagonal Matrix Using VBA Macro” on page 1-21
• “Executing Spreadsheet Link Functions” on page 1-31
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Create Diagonal Matrix Using VBA Macro
This example shows how to execute Spreadsheet Link functions to export a named range in the
worksheet to MATLAB and create a diagonal matrix using a Microsoft Excel VBA macro.

The example assumes that MATLAB is running after Microsoft Excel opens. For details, see “Start
and Stop Spreadsheet Link and MATLAB” on page 1-12.

To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

In a worksheet, enter the numbers 1 through 5 into the range of cells from A1 through E1. Define the
name testData for this range of cells and select it. For instructions, see Excel Help and enter the
search term: define and use names in formulas.

The named range testData appears in the Name Box.

On the Developer tab in Microsoft Excel, click Visual Basic. The Visual Basic Editor window opens.

Insert a new module and create a diagonal matrix from the data in testData. To insert the module,
select Insert > Module. In the Code section, enter this VBA code that contains a macro named
Diagonal.

Sub Diagonal()
    MLPutRanges
    MLEvalString "b = diag(testData);"
    MLGetMatrix "b", "A3"
    MatlabRequest
End Sub

The Diagonal macro exports the named range into the MATLAB variable testData using the
MLPutRanges function. Then, the macro uses the MLEvalString function to execute MATLAB code.
The MATLAB code creates a diagonal matrix from the data in testData using the diag function. The
code assigns the diagonal matrix to the MATLAB variable b. Then, the macro uses the MLGetMatrix
function to import the diagonal matrix into the worksheet.

Copy and paste the code into the Visual Basic Editor from the HTML version of the documentation.

For details about working with modules, see Excel Help.

Run the macro by clicking Run Sub/UserForm (F5). For details about running macros, see Excel
Help.

The diagonal matrix displays in the worksheet cells A3 through E7.
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See Also
MLEvalString | MLPutRanges | diag

More About
• “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
• “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
• “Create Diagonal Matrix Using Worksheet Cells” on page 1-19
• “Executing Spreadsheet Link Functions” on page 1-31
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Find and Execute MATLAB Function Using MATLAB Function
Wizard

This example shows how to find and execute the triu function using the MATLAB Function Wizard
for Spreadsheet Link. You can use the Function Wizard to find any MATLAB function.

First, open the MATLAB Function Wizard from Microsoft Excel. From the Home tab, select the
MATLAB group option MATLAB Function Wizard. Locate the triu MATLAB function, choose the
function signature, and then execute it.

Alternatively, you can execute the function in a Microsoft Excel worksheet cell by using function
matlabfcn or matlabsub.

List Folders and Function Categories

All folders or categories in the current search path appear in the Select a category field of the
MATLAB Function Wizard. Click an entry to select it. Each entry in the list appears as a folder path
and a description read from the Contents.m file in that folder. If no Contents.m file is found, the
category list displays contains this message:

finance\finsupport -(No table of contents file)
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Refresh and Select Category

Click Update to refresh the category list. For details about the search path, see path.

The Select a function field displays a list of available functions for that category. Click the function
name you want to execute. For help with the selected function, view the Function Help field.

Select Function Signature and Enter Formula

The Select a function signature field displays available signatures for that function. Click a
function signature to select it. The Function Arguments dialog box appears.

Specify the worksheet cell that contains the input argument X. By default, the output of the selected
function appears in the current worksheet cell using the function matlabfcn.

See Also
matlabfcn | matlabsub

More About
• “Find Custom MATLAB Function Using MATLAB Function Wizard” on page 1-25
• “Executing Spreadsheet Link Functions” on page 1-31
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Find Custom MATLAB Function Using MATLAB Function Wizard
This example shows how to write a custom function and find it using the MATLAB Function Wizard
for Spreadsheet Link. To execute MATLAB functions using the MATLAB Function Wizard, see “Find
and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23.

Create and save a custom function in MATLAB. First, create a help header in the function that
contains supported function signatures to use with the MATLAB Function Wizard. Write the function
that calculates the Fibonacci numbers, and then save the function in the folder Documents\MATLAB.

function f = fibonacci(n)
% FIBONACCI(N)  Calculate the Nth Fibonacci number.
% N must be a positive integer.
    if n < 0
        error('Invalid number.')
    elseif n == 0
        f = 0;
    elseif n == 1
        f = 1;
    else
        f = fibonacci(n - 1) + fibonacci(n - 2);
    end;
end

For writing MATLAB functions, see “Create Functions in Files”.

Add the folder where you saved the function to the MATLAB search path. You can use the pathtool
function or select Set Path in the MATLAB Toolstrip.

Open the MATLAB Function Wizard in Microsoft Excel using either the Microsoft Excel ribbon or
context menu. Select the folder where you saved your function.
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To execute this function, follow the steps in “Find and Execute MATLAB Function Using MATLAB
Function Wizard” on page 1-23.

See Also
matlabfcn | matlabsub

More About
• “Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
• “Executing Spreadsheet Link Functions” on page 1-31
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Return Multiple Output Arguments from MATLAB Function
This example shows how to execute a MATLAB function that returns multiple output arguments in
Microsoft Excel using a Microsoft Excel VBA macro. The macro writes multiple output arguments
from the MATLAB workspace to Microsoft Excel cells.

To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

This example calculates the singular value decomposition of a matrix using svd.

In the Microsoft Excel cells from A1 through C3, create a range of data. Enter numbers from 1
through 3 in cells A1 through A3. Enter numbers from 4 through 6 in cells B1 through B3. Enter
numbers from 7 through 9 in cells C1 through C3.

Create a Microsoft Excel VBA macro named applysvd. For details about creating macros, see Excel
Help.

Public Sub applysvd()
    MLOpen
    MLPutMatrix "x", Range("A1:C3")
    MLEvalString ("[u,s,v] = svd(x);")
    MLGetMatrix "u", "A5"
    MLGetMatrix "s", "A9"
    MLGetMatrix "v", "A13"
    MatlabRequest
    MLClose
End Sub

The macro:

1 Starts MATLAB.
2 Sends the data in the A1 through C3 cell range to the MATLAB workspace and assigns it to the

MATLAB variable x.
3 Runs svd with the input argument x and output arguments u, s, and v.
4 Individually retrieves data for one output argument into a specific Microsoft Excel cell while

accounting for the size of each output data matrix to avoid overwriting data. For the first output
argument, the macro retrieves the data for the output argument u into cell A5.

5 Closes MATLAB.

Run applysvd. MATLAB runs svd and populates the specified cells with data from the three output
arguments.
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For details about running macros, see Excel Help.

See Also
MLClose | MLEvalString | MLGetMatrix | MLOpen | MLPutMatrix | svd

More About
• “Create Diagonal Matrix Using VBA Macro” on page 1-21
• “Executing Spreadsheet Link Functions” on page 1-31
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Convert Dates Between Microsoft Excel and MATLAB
Default Microsoft Excel date numbers represent the number of days that have passed since January
1, 1900. For example, January 1, 1950 is represented as 18264 in the Excel software.

However, MATLAB date numbers represent the number of days that have passed since January 1,
0000, so January 1, 1950 is represented as 712224 in the MATLAB software. Therefore, the difference
in dates between the Excel software and the MATLAB software is a constant, 693960 (712224 minus
18264).

To use date numbers in MATLAB calculations, apply the 693960 constant as follows:

• Add it to Excel date numbers that are read into the MATLAB software.
• Subtract it from MATLAB date numbers that are read into the Excel software.

Note If you use the optional Excel 1904 date system, the constant is 695422.

Dates are stored internally in the Excel software as numbers and are unaffected by locale.

See Also

Related Examples
• “Create Diagonal Matrix Using Worksheet Cells” on page 1-19
• “Create Diagonal Matrix Using VBA Macro” on page 1-21
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Localization Information
This document uses Microsoft Excel with an English (United States) Microsoft Windows
regional setting for illustrative purposes. If you use Spreadsheet Link with a non-English (United
States) Windows desktop environment, certain syntactical elements might not work as illustrated.
For example, you might have to replace the comma delimiter within Spreadsheet Link commands
with a semicolon or other operator.

Please consult your Windows documentation to determine which regional setting differences exist
among non-US versions.

See Also

Related Examples
• “Setting Spreadsheet Link Preferences” on page 1-10
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Executing Spreadsheet Link Functions
Spreadsheet Link functions manage the connection and data exchange between Microsoft Excel and
MATLAB, without leaving the Microsoft Excel environment.

To execute Spreadsheet Link functions, you must:

• Understand the differences between these functions and Microsoft Excel functions.
• Choose the right function type, execution method, and calculation mode for your situation.
• Decide how to specify functions and arguments.

Spreadsheet Link and Microsoft Excel Function Differences
In Microsoft Excel, entering Spreadsheet Link functions can be similar to Microsoft Excel functions.
The differences include:

• Spreadsheet Link functions perform an action, while Microsoft Excel functions return a value.
• Spreadsheet Link function names are case-insensitive. Entering either MLPutMatrix or

mlputmatrix executes the MLPutMatrix function.
• MATLAB function names and variable names are case-sensitive. For example, BONDS, Bonds, and

bonds are three different MATLAB variables.

Spreadsheet Link Function Types
There are link management and data management functions in Spreadsheet Link.

Link management functions initialize, start, and stop the Spreadsheet Link and MATLAB software.
Execute the matlabinit function from the Excel Tools > Macro menu or in macro subroutines.

Data management functions copy data between Microsoft Excel and the MATLAB workspace. These
functions execute MATLAB commands in Microsoft Excel. Except for MLPutVar and MLGetVar, you
can execute any data management function as a worksheet cell formula or in a VBA macro. The
MLPutVar and MLGetVar functions execute only in VBA macros.

Spreadsheet Link Function Execution Method
You can execute Spreadsheet Link functions using these various methods.
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Execution Method Advantages Limitations
Microsoft Excel ribbon Quickly access common

Spreadsheet Link functionality
in the MATLAB group:

• matlabinit
• MLPutMatrix
• MLPutRanges
• MLGetMatrix
• MLEvalString
• MLGetFigure
• MATLAB Function Wizard

(For details, see “Find and
Execute MATLAB Function
Using MATLAB Function
Wizard” on page 1-23.)

• Preferences (For details, see
“Setting Spreadsheet Link
Preferences” on page 1-10.)

Full Spreadsheet Link
functionality is unavailable.

Microsoft Excel context menu Quickly access common
Spreadsheet Link functionality
in a worksheet cell:

• MLPutMatrix
• MLPutRanges
• MLEvalString
• MLGetFigure
• MATLAB Function Wizard

(For details, see “Find and
Execute MATLAB Function
Using MATLAB Function
Wizard” on page 1-23.)

• MLGetMatrix

Full Spreadsheet Link
functionality is unavailable.

Microsoft Excel worksheet cell • Execute any Spreadsheet
Link function.

• Execute MATLAB functions.

You cannot execute MLGetVar,
MLPutVar, or matlabinit
within a worksheet cell.

Microsoft Excel VBA macro • Execute any Spreadsheet
Link function.

• Execute MATLAB functions.
• Execute advanced VBA code.

Requires knowledge of
Microsoft Visual Basic.
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Execution Method Advantages Limitations
MATLAB Function Wizard • Find MATLAB function by

category or folder.
• Explore MATLAB function

syntaxes.
• Execute MATLAB function by

choosing a syntax and
specifying arguments.

• Execute custom MATLAB
function.

Execute a MATLAB function
using only the Spreadsheet Link
functions matlabfcn and
matlabsub.

Specify Spreadsheet Link Function in Microsoft Excel
When you specify a Spreadsheet Link function in a worksheet cell, enter the formula by starting with
a + or = sign. Then, enclose function arguments in parentheses. This example formula uses the
MLPutMatrix function to export data in cell C10 into matrix A.

=MLPutMatrix("A",C10)

In VBA macros, leave a space between the function name and the first argument. Do not use
parentheses.

MLPutMatrix "A",C10

To change the active cell when an operation completes, select Excel Tools Options > Edit > Move
Selection after Enter. This action provides a useful confirmation for lengthy operations.

Set Calculation Mode
Spreadsheet Link functions are most effective in automatic calculation mode. To automate the
recalculation of a Spreadsheet Link function, add a cell reference to a cell whose value changes. For
example, the MLPutMatrix function executes again when the value in cell C1 changes.

=MLPutMatrix("bonds", D1:G26) + C1

To use MLPutMatrix in manual calculation mode:

1 Enter the function into a cell.
2 Press F2.
3 Press Enter. The function executes.

Spreadsheet Link functions do not automatically adjust cell addresses. If you use explicit cell
addresses in a function, edit the function arguments to reference a new cell address when you:

• Insert or delete rows or columns.
• Move or copy the function to another cell.

Specify Spreadsheet Link Function Arguments
You can specify arguments in Spreadsheet Link functions using the variable name or by referencing
the data location for the argument.
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Note: Spreadsheet Link functions expect the default reference style (A1) worksheet cell references.
The columns must be designated with letters and the rows with numbers. If your worksheet shows
columns designated with numbers instead of letters, then follow this procedure:

1 Select Tools > Options.
2 Click the General tab.
3 Under Settings, clear the R1C1 reference style check box.

Variable-Name Arguments

• You can directly or indirectly specify a variable-name argument in most Spreadsheet Link
functions.

• To specify a variable name directly, enclose it in double quotation marks, for example,
=MLDeleteMatrix("Bonds").

• To specify a variable name as an indirect reference, enter it without quotation marks. The
function evaluates the contents of the argument to retrieve the variable name. The argument
must be a worksheet cell address or range name; for example, =MLDeleteMatrix(C1).

Note Spreadsheet Link functions do not support global variables. When exchanging data between
Excel and MATLAB, the software uses the base workspace. Variables in the base workspace exist
until you clear them or end your MATLAB session.

Data-Location Arguments

• A data-location argument must be a worksheet cell address or range name.
• Do not enclose a data-location argument in quotation marks (except in MLGetMatrix, which has

unique argument conventions).
• A data-location argument can include a worksheet number such as Sheet3!B1:C7 or Sheet2!

OUTPUT.

Tip: You can reference special characters as part of a worksheet name in MLGetMatrix or
MLPutMatrix by enclosing the worksheet name within single quotation marks ('').

Specify MATLAB Function in MATLAB Function Wizard
After you find the MATLAB function or custom function in the MATLAB Function Wizard, you can
specify the syntax and arguments. Then, Spreadsheet Link specifies this command for evaluation in
the MATLAB workspace.

To execute a MATLAB function with multiple outputs, specify where to write the output.

• Specifying a target range of cells using the Optional output cell(s) field causes the selected
function to appear in the current worksheet cell as an argument of matlabsub. The matlabsub
function includes an argument that indicates where to write the output. For example, the data
from A2 is input to the rand function and the target cell for output is B2:

=matlabsub("rand","Sheet1!$B$2",Sheet1!$A$2)
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• Although the Function Wizard lets you specify multiple output cells, it does not return multiple
outputs. If you specify a range of output cells, the wizard returns the first output argument
starting in the first output cell. For example, if a function returns two elements a and b, and you
specify A1:A2 as output cells, the Function Wizard displays a in cell A1. The Function Wizard
discards element b. If an output is a matrix, the Function Wizard displays all elements of that
matrix starting in the first output cell.

For multiple output arguments, see “Return Multiple Output Arguments from MATLAB Function”
on page 1-27.

To execute multiple MATLAB functions or use MATLAB objects, write a wrapper function.

• The Function Wizard does not allow simultaneous execution of multiple MATLAB functions. Write
a wrapper function instead. For example, to plot historical closing-price data from Bloomberg®,
enter this code in MATLAB and save it as a function.

function plotbloombergdata(s)
% plotbloombergdata is a wrapper function that connects to 
% Bloomberg(R), retrieves historical closing-price data for 
% the year 2015, and plots the prices for a given 
% Bloomberg(R) security s.
    c = blp;
    f = 'LAST_PRICE';
    fromdate = '01/01/2015';
    todate = '12/31/2015';
    d = history(c,s,f,fromdate,todate);
    plot(d(:,1),d(:,2))
    close(c)
end

For details about writing functions, see “Create Functions in Files”.
• Microsoft Excel has no context for MATLAB objects. To work with MATLAB objects, such as

connections to service providers, write a wrapper function. The wrapper function executes the
functions that create and manipulate these objects.

See Also
MLEvalString | MLGetMatrix | MLPutMatrix | matlabfcn | matlabinit

More About
• “Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
• “Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
• “Create Diagonal Matrix Using Worksheet Cells” on page 1-19
• “Create Diagonal Matrix Using VBA Macro” on page 1-21
• “Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
• “Localization Information” on page 1-30
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Solving Problems with the Spreadsheet
Link Software

• “Model Data Using Regression and Curve Fitting” on page 2-2
• “Interpolate Thermodynamic Data” on page 2-8
• “Price Stock Options Using Binomial Model” on page 2-11
• “Plot Efficient Frontier of Financial Portfolios” on page 2-14
• “Map Time and Bond Cash Flows” on page 2-17
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Model Data Using Regression and Curve Fitting
This example shows how to execute MATLAB data regression and curve fitting in Microsoft Excel
using a worksheet and a VBA macro.

The example organizes and displays the input and output data in a Microsoft Excel worksheet.
Spreadsheet Link functions copy the data to the MATLAB workspace and execute MATLAB
computational and graphic functions. The VBA macro also returns output data to a worksheet.

To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

Open the ExliSamp.xls file and select the Sheet1 worksheet. For help finding the ExliSamp.xls
file, see “Installation” on page 1-3.

Sheet1 of the spreadsheet contains the named range DATA, which consists of the example data set in
worksheet cells A4 through C28.

Model Data in Worksheet
To perform regression and curve fitting, execute the specified Spreadsheet Link functions in
worksheet cells.

1 Execute the Spreadsheet Link function that copies the sample data set to the MATLAB workspace
by double-clicking the cell E5 and pressing Enter. The data set contains 25 observations of three
variables. There is a strong linear dependence among the observations. In fact, they are close to
being scalar multiples of each other.
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2 Execute the functions in cells E8, E9, and E10. The Spreadsheet Link functions in these cells
regress the third column of data on the other two columns, and create:

• A single vector y containing the third-column data
• A three-column matrix A, which consists of a column of 1s followed by the rest of the data

3 Execute the function in cell E13. This function calculates the regression coefficients by using the
MATLAB back slash (\) operation to solve the overdetermined system of linear equations,
A*beta = y.

4 Execute the function in cell E16. MATLAB matrix-vector multiplication produces the regressed
result, fit.

5 Execute the functions in cells E19, E20, and E21. These functions:

a Compare the original data with fit.
b Sort the data in increasing order and apply the same permutation to fit.
c Create a scalar for the number of observations.

6 Execute the functions in cells E24 and E25. Fit a polynomial equation to the data for a fifth-
degree polynomial. The MATLAB polyfit function automates setting up a system of
simultaneous linear equations and solutions for the coefficients. The polyval function then
evaluates the resulting polynomial at each data point to check the goodness of the fit newfit.

7 Execute the function in cell E28. The MATLAB plot function graphs the original data (blue
circles), the regressed result fit (dashed red line), and the polynomial result (solid green line).
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Since the data is closely correlated, but not exactly linearly dependent, the fit curve (dashed
line) shows a close, but not exact, fit. The fifth-degree polynomial curve newfit is a more
accurate mathematical model for the data.

Model Data Using VBA Macro
To model the data using a VBA macro, execute the Spreadsheet Link functions in a VBA macro.

1 In the ExliSamp.xls file, click the Sheet2 tab. The worksheet for this example appears.
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Cell A4 calls the macro CurveFit, which you can examine in the Microsoft Visual Basic
environment.
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While this module is open, ensure that the Spreadsheet Link add-in is enabled. To enable it, see
“Add-In Setup” on page 1-5. After the add-in is enabled, the Project Explorer lists it under the
References folder.

2 Execute the CurveFit macro by double-clicking the cell A4 and pressing Enter. The macro runs
the Spreadsheet Link functions. When the macro finishes, the input and output data appears in
worksheet cells A7:C31.

• Column A contains the original data y (sorted).
• Column B contains the corresponding regressed data fit.
• Column C contains the polynomial data newfit.
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See Also
MLEvalString | MLGetMatrix | MLPutMatrix | plot | polyfit | polyval

More About
• “Interpolate Thermodynamic Data” on page 2-8
• “Price Stock Options Using Binomial Model” on page 2-11
• “Plot Efficient Frontier of Financial Portfolios” on page 2-14
• “Map Time and Bond Cash Flows” on page 2-17
• “Executing Spreadsheet Link Functions” on page 1-31
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Interpolate Thermodynamic Data
This example shows how to interpolate data using Spreadsheet Link to invoke MATLAB functions in
Microsoft Excel.

The example uses the two-dimensional data-gridding interpolation function griddata on
thermodynamic data, where volume has been measured for time and temperature values. The
griddata function finds the volume values underlying the two-dimensional time-temperature
function for a new set of time and temperature coordinates.

To organize and display the original data and the interpolated output data, you can use Microsoft
Excel worksheets.

Open the ExliSamp.xls file and select the Sheet3 worksheet. For help finding the ExliSamp.xls
file, see “Installation” on page 1-3.

This worksheet contains measured thermodynamic data in cell ranges A5 through A29, B5 through
B29, and C5 through C29. The time and temperature values for interpolation are in cell ranges E7
through E30 and F6 through T6, respectively.

1 Execute the Spreadsheet Link function that passes the Time, Temp, and Volume labels to the
MATLAB workspace by double-clicking the cell A33 and pressing Enter.
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2 Copy the original time data to the MATLAB workspace by executing the function in the cell A34.
To copy the original temperature data, execute the function in the cell A35. To copy the original
volume data, execute the function in cell A36.

3 Copy the interpolation time values to the MATLAB workspace by executing the function in cell
A39. To copy the interpolation temperature values, execute the function in cell A40.

4 Execute the function in cell A43. The griddata function performs two-dimensional interpolation
that generates the interpolated volume data using the inverse distance method.

5 Transpose the interpolated volume data and copy it to the Excel worksheet by executing the
functions in cells A46 and A47. The data fills the cell range F7:T30.

6 Execute the function in cell A50. The MATLAB software plots and labels the interpolated data on
a three-dimensional color surface, with the color proportional to the interpolated volume data.
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To generate different volume values, close the figure and change the measured thermodynamic
data in cells A5:C29. Then, execute all the Spreadsheet Link functions again. The worksheet
updates with new volume rates and MATLAB generates a new figure of the interpolated volume
data.

See Also
MLEvalString | MLGetMatrix | MLPutMatrix | griddata | surf

More About
• “Model Data Using Regression and Curve Fitting” on page 2-2
• “Price Stock Options Using Binomial Model” on page 2-11
• “Plot Efficient Frontier of Financial Portfolios” on page 2-14
• “Map Time and Bond Cash Flows” on page 2-17
• “Executing Spreadsheet Link Functions” on page 1-31
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Price Stock Options Using Binomial Model
This example uses the binomial model to price a stock option. The binomial model assumes that the
probability of each possible price over time follows a binomial distribution. Price values can become
either one up or one down over any short time period. Plotting these two values over time is known as
building a binomial tree. For details about the binomial model, see “Pricing and Analyzing Equity
Derivatives” (Financial Toolbox).

The example organizes and displays the input and output data in a Microsoft Excel worksheet.
Spreadsheet Link functions copy data to a MATLAB matrix, calculate prices, and return data to the
worksheet.

Open the ExliSamp.xls file and select the Sheet4 worksheet. For help finding the ExliSamp.xls
file, see “Installation” on page 1-3.

This worksheet contains these named ranges:

• B4:B10 named bindata. Two cells in bindata contain formulas:

• B7 contains =5/12
• B8 contains =1/12

• B15 named asset_tree.
• B23 named value_tree.
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Note This example requires Financial Toolbox™, Statistics and Machine Learning Toolbox™, and
Optimization Toolbox™.

1 Execute the Spreadsheet Link function that copies the asset data to the MATLAB workspace by
double-clicking the cell D5 and pressing Enter.

2 Execute the function that calculates the binomial prices in cell D8.
3 Copy the price data to the worksheet by executing the functions in cells D11 and D12.

The data in the worksheet updates.

The asset price tree contains these prices:

• Period 1 — The up and down prices
• Period 2 — The up-up, up-down, and down-down prices
• Period 3 — The up-up-up, up-up, down-down, and down-down-down prices
• And so on.

The option value tree gives the associated option value for each node in the price tree. The
option value is zero for prices significantly above the exercise price. Ignore the zeros that
correspond to a zero in the price tree.

You can generate different binomial prices by changing the data in the cell range B4:B10 and
executing the Spreadsheet Link functions again. If you increase the time to maturity in cell B7 or
change the time increment in cell B8, enlarge the output tree areas as needed.
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See Also
MLEvalString | MLGetMatrix | MLPutMatrix | binprice

More About
• “Model Data Using Regression and Curve Fitting” on page 2-2
• “Interpolate Thermodynamic Data” on page 2-8
• “Plot Efficient Frontier of Financial Portfolios” on page 2-14
• “Map Time and Bond Cash Flows” on page 2-17
• “Pricing and Analyzing Equity Derivatives” (Financial Toolbox)
• “Executing Spreadsheet Link Functions” on page 1-31
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Plot Efficient Frontier of Financial Portfolios
This example analyzes three portfolios with given rates of return for six time periods by executing
MATLAB functions using Spreadsheet Link. In actual practice, these functions can analyze many
portfolios over many time periods, limited only by the amount of computer memory available.

For details about the efficient frontier of financial portfolios, see “Analyzing Portfolios” (Financial
Toolbox). To learn about portfolio optimization theory, see “Portfolio Optimization Theory” (Financial
Toolbox).

The example organizes and displays the input and output data in a Microsoft Excel worksheet.
Spreadsheet Link functions copy data to a MATLAB matrix, perform calculations using Financial
Toolbox functions, and return data to the worksheet.

Open the ExliSamp.xls file and select the Sheet5 worksheet. For help finding the ExliSamp.xls
file, see “Installation” on page 1-3.

This worksheet contains rates of return for three different portfolios: Global, Corporate Bond, and
Small Cap.

Note This example requires Financial Toolbox, Statistics and Machine Learning Toolbox, and
Optimization Toolbox.

1 Execute the Spreadsheet Link function that transfers the plot labels for the x-axis and y-axis to
the MATLAB workspace by double-clicking the cell A15 and pressing Enter.

2 Copy the portfolio return data to the MATLAB workspace by executing the function in the cell
A16.

3 Generate efficient frontier data for 20 points along the frontier by executing the Financial
Toolbox functions in A19 and A20.
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4 Copy the output data to the Excel worksheet by executing the Spreadsheet Link functions in A23,
A24, and A25.

The output data contains the highest rate of return ROR for a given risk. The output data also
contains the weighted investment in each portfolio Weights that achieves that rate of return.

5 Plot the efficient frontier for the same portfolio data by executing the Financial Toolbox functions
in cell A28.

 Plot Efficient Frontier of Financial Portfolios
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The light blue line shows the efficient frontier. Observe the change in slope above a 6.8% return
because the Corporate Bond portfolio no longer contributes to the efficient frontier.

To generate different efficient frontier data, close the figure and change the data in cells B4:D9.
Then, execute all the Spreadsheet Link functions again. The worksheet updates with new frontier
data and MATLAB generates a new efficient frontier plot.

See Also
MLEvalString | MLGetMatrix | MLPutMatrix | ewstats | portopt

More About
• “Model Data Using Regression and Curve Fitting” on page 2-2
• “Interpolate Thermodynamic Data” on page 2-8
• “Price Stock Options Using Binomial Model” on page 2-11
• “Map Time and Bond Cash Flows” on page 2-17
• “Executing Spreadsheet Link Functions” on page 1-31
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Map Time and Bond Cash Flows
This example shows how to use Financial Toolbox and Spreadsheet Link to calculate a set of cash flow
amounts and dates for a portfolio of five bonds.

Open the ExliSamp.xls file and select the Sheet6 worksheet. For help finding the ExliSamp.xls
file, see “Installation” on page 1-3.

This worksheet contains the maturity dates and coupon rates for five bonds.

Note This example requires Financial Toolbox, Statistics and Machine Learning Toolbox, and
Optimization Toolbox.

1 Execute the Spreadsheet Link function that transfers the column vector Maturity to the
MATLAB workspace by double-clicking the cell A18 and pressing Enter.

2 Transfer the column vector Coupon Rate to the MATLAB workspace by executing the function
in cell A19.

3 Transfer the settlement date to the MATLAB workspace by executing the function in cell A20.
4 Calculate cash flow amounts and dates by executing the Financial Toolbox functions in cells A23

and A24.
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5 Transform the dates into a cell array of character vectors by executing the functions in cells A27
through A29.

6 Transfer the data to the Excel worksheet by executing the functions in cells A32 through A34.

7 Display a plot of cash flows for each bond by executing the function in cell A37.

2 Solving Problems with the Spreadsheet Link Software
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To generate cash flows for a different set of five bonds, close the figure and change the bond data in
cells B8:C12. Then, execute all the Spreadsheet Link functions again. The worksheet updates with
new cash flow dates and amounts and MATLAB generates a new figure of the cash flows.

See Also
MLEvalString | MLGetMatrix | MLPutMatrix | cfamounts | cfplot | x2mdate

More About
• “Model Data Using Regression and Curve Fitting” on page 2-2
• “Interpolate Thermodynamic Data” on page 2-8
• “Price Stock Options Using Binomial Model” on page 2-11
• “Plot Efficient Frontier of Financial Portfolios” on page 2-14
• “Executing Spreadsheet Link Functions” on page 1-31
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Error Messages and Troubleshooting

• “Worksheet Cell Errors” on page 3-2
• “Microsoft Excel Errors” on page 3-5
• “Data Errors” on page 3-8
• “License Errors” on page 3-10
• “Startup Errors” on page 3-11
• “Audible Error Signals” on page 3-12
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Worksheet Cell Errors
You might see these error messages displayed in a worksheet cell.

The first column contains worksheet cell error messages. The error messages begin with the number
sign (#). Most end with an exclamation point (!) or with a question mark (?).

3 Error Messages and Troubleshooting
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Worksheet Cell Error Messages 

Error Message Meaning Solution
#COLS>#MAXCOLS! Your MATLAB variable exceeds the

Microsoft Excel limit of #MAXCOLS!
columns.

This is a limitation in the Excel product.
Try the computation with a variable
containing fewer columns.

#COMMAND! This error message represents any
error that appears at the MATLAB
command line. You can show the full
error message from the MATLAB
command line by using the
MLShowMatlabErrors function. Or,
you can set the corresponding
preference in the Preferences dialog
box available from the MATLAB group
on the Excel Home tab.

Troubleshoot the MATLAB error.

#DIMENSION! You used MLAppendMatrix and the
dimensions of the appended data do
not match the dimensions of the matrix
you want to append.

Verify the matrix dimensions and the
appended data dimensions, and correct
the argument. For more information,
see the MLAppendMatrix reference
page.

#INVALIDNAME! You entered an invalid variable name. Ensure that you use valid MATLAB
variable names. MATLAB variable
names must start with a letter, followed
by letters, digits, or underscores. For
details, see “Variable Names”.

#INVALIDTYPE! You specified an illegal MATLAB data
type with MLGetVar or MLGetMatrix.

Make sure to use the supported
MATLAB data types.

#MATLAB? You used a Spreadsheet Link function
and no MATLAB software session is
running.

Start the Spreadsheet Link and
MATLAB software. See “Start and Stop
Spreadsheet Link and MATLAB” on
page 1-12.

#NAME? The function name is unrecognized.
The excllink.xla add-in is not
loaded, or the function name might be
misspelled.

Be sure the excllink.xla add-in is
loaded. See “Add-In Setup” on page 1-5.
Check the spelling of the function name.
Correct typing errors.

#NONEXIST! You referenced a nonexistent matrix in
an MLGetMatrix or MLDeleteMatrix
function. The matrix name might be
misspelled.

Also, you receive the #NONEXIST!
error when you attempt to use
matlabfcn to obtain an output.

Verify the spelling of the MATLAB
matrix. Use the MATLAB whos
command to display existing matrices.
Correct typing errors.

#ROWS>#MAXROWS! Your MATLAB variable exceeds the
Excel limit of #MAXROWS! rows.

This is a limitation in the Excel product.
Try the computation with a variable
containing fewer rows.
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Error Message Meaning Solution
#SYNTAX? You entered a Spreadsheet Link

function with incorrect syntax. For
example, you did not specify double
quotation marks ("), or you specified
single quotation marks (') instead of
double quotation marks.

Verify and correct the function syntax.

#VALUE! An argument is missing from a
function, or a function argument is the
wrong type.

Supply the correct number of function
arguments, of the correct type.

#VALUE! A macro subroutine uses
MLGetMatrix followed by
MatlabRequest, which is correct
standard usage. A macro function calls
that subroutine, and you execute that
function from a worksheet cell. The
function works correctly, but this
message appears in the cell.

Since the function works correctly,
ignore the message. Or, in this special
case, remove MatlabRequest from the
subroutine.

#INVALIDRANGE! The named range is defined
incorrectly, or the named range spans
multiple worksheets.

Select a range of data on only one
worksheet and create an appropriate
name for the range of data. For
instructions about defining names, see
Excel Help.

Note When you open an Excel worksheet that contains Spreadsheet Link functions, the Excel
software tries to execute the functions from the bottom up and right to left. Excel might generate cell
error messages such as #COMMAND! or #NONEXIST!. This is expected behavior, so ignore the
messages and do the following:

1 Close the MATLAB figure windows.
2 Execute the cell functions again one at a time in the correct order by pressing F2, and then

Enter.

3 Error Messages and Troubleshooting

3-4



Microsoft Excel Errors
The Excel software can display these error messages.

Error Message Cause of Error Solution
Error in formula You entered a formula

incorrectly. Common errors
include a space between the
function name and the left
parenthesis; or missing, extra,
or mismatched parentheses.

Note  If you use the
Spreadsheet Link software with
a non-English (United
States) Windows desktop
environment, certain syntactical
elements might not work. For
details, see “Localization
Information” on page 1-30.

Review the entry and correct
typing errors.

Can't find project or
library

or

Compile error: Sub or
Function not defined

You executed a macro and the
location of excllink.xla is
incorrect or not specified.

Click OK. The References
window opens. Remove the
check mark from MISSING:
excllink.xla. Find
excllink.xla in its correct
location, select its check box in
the References window, and
click OK. Or, select Tools >
References to open the
References window. Select the
box named
SpreadsheetLink2007_2010.
Click OK.

Run-time error '1004':
Cells method of
Application class failed

You used MLGetMatrix and the
matrix is larger than the space
available in the worksheet. This
error destabilizes the
Spreadsheet Link software
session and changes worksheet
calculation mode to manual.

Click OK. Reset worksheet
calculation mode to automatic,
and save your worksheet as
needed. Restart the Excel,
Spreadsheet Link, and MATLAB
software sessions.
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Error Message Cause of Error Solution
MATLAB failed to check
out a license of
Spreadsheet Link or does
not have a valid
installation of
Spreadsheet Link

You entered an invalid license
pass code or did not install
Spreadsheet Link properly.

Ensure that you entered the
license pass code properly.
Reinstall the Spreadsheet Link
add-on. (See “Installation” on
page 1-3.) If you followed the
installation guidelines, used a
proper pass code, and you are
still unable to start the
Spreadsheet Link software,
contact your MathWorks®

representative.
Datasource: Excel;
prompt for user name and
password

This message appears when an
attempt to connect to the Excel
software from the Database
Toolbox™ software fails.

Ensure that the Excel worksheet
referenced by the data source
exists, then retry the
connection.

Could not load some
objects because they are
not available on this
machine

This message appears when
Excel 2013 is not configured
properly.

From the Windows Control
Panel, remove Microsoft Office
2010 in the programs list.
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Error Message Cause of Error Solution
This error appears when you
start the automation server
from the Excel interface, and
multiple versions of the
MATLAB software are installed
on your desktop.

To correct this error, ensure that
you have administrator
privileges on your machine and
then perform the following:

1 Shut down all MATLAB and
Excel instances.

2 Open a command prompt,
and using cd, change to the
bin\win64 subfolder of the
MATLAB installation folder.

3 Type the command:

.\matlab /regserver
4 When the MATLAB session

starts, close it. Using /
regserver fixes the
registry entries.

5 Start an Excel session. The
Spreadsheet Link add-in
now loads properly.

6 Verify that the Spreadsheet
Link software is working by
entering the following
command from the
Command Window:

a = 3.14159
7 Enter the following formula

in cell A1 of the open Excel
worksheet:

=mlgetmatrix("a","a1")
8 The value 3.14159 appears

in cell A1.
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Data Errors
In this section...
“Matrix Data Errors” on page 3-8
“Errors When Opening Saved Worksheets” on page 3-8

Matrix Data Errors
Data in the MATLAB or Microsoft Excel workspaces may produce the following errors.

Data Errors

Data Error Cause Solution
MATLAB matrix cells contain
zeros (0).

Corresponding Excel worksheet cells
are empty.

Excel worksheet cells must contain
only numeric or string data.

MATLAB matrix is a 1-by-1
zero matrix.

You used quotation marks around the
data-location argument in
MLPutMatrix or MLAppendMatrix.

Correct the syntax to remove quotation
marks.

MATLAB matrix is empty ([ ]). You referenced a nonexistent VBA
variable in MLPutVar.

Correct the macro; you may have typed
the variable name incorrectly.

VBA matrix is empty. You referenced a nonexistent MATLAB
variable in MLGetVar.

Correct the macro; you may have typed
the variable name incorrectly.

Errors When Opening Saved Worksheets
This section describes errors that you may encounter when opening saved worksheets.

• When you open an Excel worksheet that contains Spreadsheet Link functions, the Excel software
tries to execute the functions from the bottom up and right to left. Excel may generate cell error
messages such as #COMMAND! or #NONEXIST!. This is expected behavior. Do the following:

1 Ignore the messages.
2 Close MATLAB figure windows.
3 Execute the cell functions again one at a time in the correct order by pressing F2, and then

Enter.
• If you save an Excel worksheet containing Spreadsheet Link functions, and then reopen it in an

environment where the excllink.xla add-in is in a different location, you may see the message:
This document contains links: Re-establish links?

To address this issue, do the following:

1 Click No.
2 Select Edit > Links.
3 In the Links dialog box, click Change Source.
4 In the Change Links dialog box, select matlabroot\toolbox\exlink\excllink.xla.
5 Click OK.
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The Excel software executes each function as it changes its link. You may see MATLAB figure
windows and hear error beeps as the links change and functions execute; ignore them.

6 In the Links dialog box, click OK.

The worksheet now connects to the Spreadsheet Link add-in.

Or, instead of using the Links menu, you can manually edit the link location in each affected
worksheet cell to show the correct location of excllink.xla.
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License Errors
If you are running an automation server of MATLAB that does not have a Spreadsheet Link license
associated with it, you will receive a license error message. To correct this issue, from the MATLAB
installation that includes Spreadsheet Link, run the command:

matlab /regserver

3 Error Messages and Troubleshooting
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Startup Errors
In this section...
“MATLAB Automatic Start Error” on page 3-11
“MATLAB Version Errors” on page 3-11

MATLAB Automatic Start Error
If you have enabled MLAutoStart and MLUseFullDesktop, right-clicking a spreadsheet file in the
MATLAB Current Folder browser and choosing Open Outside MATLAB causes a MATLAB System
Error to appear. To open the file successfully, click End Now in the error window.

To avoid this issue, disable MLUseFullDesktop.

MATLAB Version Errors
If the MATLAB version is set incorrectly, MATLAB does not start and displays this error: Unable to
start MATLAB. Please register MATLAB Software as a COM Server. Set the MATLAB
version using MLProgramId.

Ensure that the correct MATLAB version appears in the Preferences dialog box before starting
MATLAB. For details, see “Setting Spreadsheet Link Preferences” on page 1-10.

If MATLAB is installed on your computer and setting the MATLAB version does not work, use the last
registered version to start MATLAB. To specify the last registered version of MATLAB:

1 Shut down all MATLAB and Excel sessions.
2 Open a command prompt window, and using cd, change to the bin\win64 subfolder of the

MATLAB installation folder.
3 Enter the command:

.\matlab /regserver

See Also
MLAutoStart | MLProgramId

More About
• “Installation” on page 1-3
• “Add-In Setup” on page 1-5
• “Setting Spreadsheet Link Preferences” on page 1-10
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Audible Error Signals
You may hear audible errors while passing data to the MATLAB workspace using MLPutMatrix or
MLAppendMatrix. These errors usually indicate that you have insufficient computer memory to carry
out the operation. Close other applications or clear unnecessary variables from the MATLAB
workspace and try again. If the error signal reoccurs, you probably have insufficient physical memory
in your computer for this operation.

3 Error Messages and Troubleshooting
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matlabfcn
Evaluate MATLAB command given Microsoft Excel data

Syntax
= matlabfcn(command,inputs)

Description
= matlabfcn(command,inputs) specifies the MATLAB command for evaluation in the MATLAB
workspace, given the input data inputs. Depending upon the MATLAB output, matlabfcn returns a
single value or string into the calling worksheet cell. If the result contains more than one value in
MATLAB, only the first value in the array returns in the calling worksheet cell. Use this syntax when
working in a worksheet cell.

Examples

Find Maximum Likelihood Estimate

Using std, find the maximum likelihood estimate of the standard deviation of data in worksheet cells
A1 through A10. Assume that the data comes from a normal population. Specify a weight of one in
cell C1. Return the result by entering this text into cell A12.

=matlabfcn("std",A1:A10,C1)

Cell A12 displays the maximum likelihood estimate of the standard deviation.

Input Arguments
command — MATLAB command to evaluate
string

MATLAB command to evaluate, specified as a string. Enclose the string in double quotes. Or, enter
the string in a cell without quotes and enter the corresponding cell reference without quotes as the
input argument.
Example: "sum"
Example: A1

inputs — MATLAB command input arguments
Excel cell reference

MATLAB command input arguments, specified as an Excel cell reference or a reference to a range of
cells. To specify multiple input arguments for a function, separate the cell references with commas.
Example: B1:B10
Example: A1:C1,A3
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Tip
• If matlabfcn fails, a standard Spreadsheet Link error displays by default; for example,

#COMMAND. To return MATLAB errors, use MLShowMatlabErrors.

See Also
MLShowMatlabErrors | matlabsub | std

Topics
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Executing Spreadsheet Link Functions” on page 1-31
“Worksheet Cell Errors” on page 3-2
“Microsoft Excel Errors” on page 3-5

Introduced before R2006a
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matlabinit
Initialize Spreadsheet Link and start MATLAB

Syntax
matlabinit

Description
matlabinit Initializes the Spreadsheet Link software and starts MATLAB process. If the
Spreadsheet Link software has been initialized and the MATLAB software is running, subsequent
invocations do nothing. Use matlabinit to start Spreadsheet Link and MATLAB sessions manually
when you have set MLAutoStart to no. If you set MLAutoStart to yes, matlabinit executes
automatically.

Tips
• To run matlabinit from the Microsoft Excel toolbar, click Tools > Macro. In the Macro Name/

Reference box, enter matlabinit and click Run. Alternatively, you can include this function in a
macro subroutine. You cannot run the matlabinit function as a worksheet cell formula or in a
macro function.

See Also
MLAutoStart | MLOpen

Topics
“Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
“Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
“Executing Spreadsheet Link Functions” on page 1-31

Introduced before R2006a
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matlabsub
Evaluate MATLAB command given Microsoft Excel data and designate output location

Syntax
= matlabsub(command,result,inputs)

Description
= matlabsub(command,result,inputs) specifies the MATLAB command for evaluation in the
MATLAB workspace, given the input data inputs. The function returns the MATLAB output into the
worksheet cell specified by result. Use this syntax when working in a worksheet cell.

Examples

Return Fourth-Order Magic Square in Worksheet Cell

Enter the number four in cell A1.

Enter this text into cell A2. Specify the function magic as the command. Return the fourth-order
magic square into the range of cells starting in cell A4. Reference cell A1 as the input argument for
the magic function.

=matlabsub("magic","A4",A1)

The fourth-order magic square displays in the range of cells from A4 through D7.

Return Fourth-Order Magic Square in Target Worksheet Cell

Enter the number four in cell A1. Enter a target cell reference to cell A6 in cell A2.
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Enter this text into cell A4. Specify the function magic as the command. Return the fourth-order
magic square into the range of cells starting in cell A6 by entering the cell reference A2. Reference
cell A1 as the input argument for the magic function.

=matlabsub("magic",A2,A1)

The fourth-order magic square displays in the range of cells from A6 through D9.

Input Arguments
command — MATLAB command to evaluate
string

MATLAB command to evaluate, specified as a string. Enclose the string in double quotes. Or, enter
the string in a cell without quotes and enter the corresponding cell reference without quotes as the
input argument.
Example: "sum"
Example: A1

result — MATLAB result
Excel cell reference

MATLAB result, specified as an Excel cell reference or range name that designates the location where
to display the result of the MATLAB command. To return the result in a specific cell, specify the cell
reference enclosed in quotes. To denote a worksheet cell address or range name that contains a cell
reference to another cell, specify the cell reference without quotes.
Example: "A3"
Example: D6
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inputs — MATLAB command input arguments
Excel cell reference

MATLAB command input arguments, specified as an Excel cell reference or a reference to a range of
cells. To specify multiple input arguments for a function, separate the cell references with commas.
Example: B1:B10
Example: A1:C1,A3

Tips
• To return an array of data to the Microsoft Excel Visual Basic for Applications (VBA) workspace,

see MLEvalString and MLGetVar.
• result must not include the cell that contains matlabsub. Do not overwrite the function itself.
• Ensure that there is enough room in the worksheet for writing matrix contents. If there is
insufficient room, the function generates a fatal error.

• If matlabsub fails, a standard Spreadsheet Link error displays by default; for example,
#COMMAND. To return MATLAB errors, use MLShowMatlabErrors.

See Also
MLShowMatlabErrors | magic | matlabfcn

Topics
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Executing Spreadsheet Link Functions” on page 1-31
“Worksheet Cell Errors” on page 3-2
“Microsoft Excel Errors” on page 3-5

Introduced before R2006a
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MLAppendMatrix
Create or append MATLAB matrix with data from Microsoft Excel worksheet

Syntax
= MLAppendMatrix(var_name,mdat)
MLAppendMatrix var_name,mdat
out = MLAppendMatrix(var_name,mdat)

Description
= MLAppendMatrix(var_name,mdat) appends data in mdat to MATLAB matrix var_name or
creates var_name if it does not exist. Use this syntax when working directly in a worksheet.

MLAppendMatrix var_name,mdat appends data in mdat to MATLAB matrix var_name or creates
var_name if it does not exist. Use this syntax in a VBA macro.

out = MLAppendMatrix(var_name,mdat) lets you catch errors when executing
MLAppendMatrix in a VBA macro. If MLAppendMatrix fails, then out is a string containing error
code. Otherwise, out is 0.

Input Arguments
var_name

Name of MATLAB matrix to which to append data.

var_name in quotes directly specifies the matrix name. var_name without quotes specifies a
worksheet cell address (or range name) that contains the matrix name. Do not use the MATLAB
variable ans as var_name.

mdat

Location of data to append to var_name.

mdat must be a worksheet cell address or range name. Do not enclose it in quotes.

mdat must contain either numeric data or string data. Data types cannot be combined within the
range specified in mdat. Empty mdat cells become MATLAB matrix elements containing zero if the
data is numeric, and empty character vectors if the data is a string.

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples
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Append Data from a Worksheet Cell Range to a MATLAB Matrix

In this example, B is a 2-by-2 MATLAB matrix. Append the data in worksheet cell range A1:A2 to B:

MLAppendMatrix("B", A1:A2)

  A1
  A2

B is now a 2-by-3 matrix with the data from A1:A2 in the third column.

Append Data from a Named Worksheet Cell Range to a MATLAB Matrix

B is a 2-by-2 MATLAB matrix. Cell C1 contains the label B, and new_data is the name of the cell
range A1:B2. Append the data in cell range A1:B2 to B:

MLAppendMatrix(C1, new_data)

  
  
A1 B1
A2 B2

B is now a 4-by-2 matrix with the data from A1:B2 in the last two rows.

Tips
• MLAppendMatrix checks the dimensions of var_name and mdat to determine how to append

mdat to var_name. If the dimensions allow appending mdat as either new rows or new columns,
it appends mdat to var_name as new rows. If the dimensions do not match, the function returns
an error.

• If mdat is not initially an Excel Range data type and you call the function from a worksheet,
MLAppendMatrix performs the necessary type coercion.

• If mdat is not an Excel Range data type and you call the function from within a Microsoft Visual
Basic macro, the call fails. The error message ByRef Argument Type Mismatch appears.

• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLPutMatrix

Introduced before R2006a
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MLAutoStart
Automatically start MATLAB

Syntax
= MLAutoStart(flag)
MLAutoStart flag
out = MLAutoStart(flag)

Description
= MLAutoStart(flag) sets automatic startup of the Spreadsheet Link and MATLAB software. A
change of state takes effect the next time an Excel session starts. Use this syntax when working
directly in a worksheet.

MLAutoStart flag sets automatic startup of the Spreadsheet Link and MATLAB software. A change
of state takes effect the next time an Excel session starts. Use this syntax in a VBA macro.

out = MLAutoStart(flag) lets you catch errors when executing MLAutoStart in a VBA macro. If
MLAutoStart fails, then out is a string containing error code. Otherwise, out is 0.

Input Arguments
flag

Either "yes" or "no".

Specify "yes" to automatically start the Spreadsheet Link and MATLAB software every time a
Microsoft Excel session starts. Specify "no" to cancel automatic startup of the Spreadsheet Link and
MATLAB software.

Default: "yes"

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

Cancel Automatic Startup of Spreadsheet Link and MATLAB

Enter this command in a worksheet:

MLAutoStart("no")
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Spreadsheet Link and MATLAB do not start on subsequent Excel session invocations.

Tips
• If Spreadsheet Link and MATLAB are running, then MLAutoStart("no") does not stop them.
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLClose | MLOpen | matlabinit

Topics
“Start Spreadsheet Link and MATLAB Automatically” on page 1-12

Introduced before R2006a
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MLProgramId
Specify MATLAB version

Syntax
= MLProgramId(version)
MLProgramId version

Description
= MLProgramId(version) specifies the MATLAB version to open when Spreadsheet Link starts in
Microsoft Excel. Enter this syntax when working in a worksheet cell.

MLProgramId version specifies the MATLAB version. Enter this syntax when working in a VBA
macro.

Examples

Specify MATLAB Version in Worksheet Cells

To open MATLAB (R2016a) in Microsoft Excel, enter this text in any worksheet cell:

=MLProgramId("9.0")

The worksheet cell displays 0 when MLProgramId runs.

To check that the preference is set, open the Preferences dialog box. The MATLAB program id box
contains 9.0. For details about the Preferences dialog box, see “Setting Spreadsheet Link
Preferences” on page 1-10.

Start MATLAB.

For troubleshooting, see “Startup Errors” on page 3-11.

Specify MATLAB Version in VBA Macro

To open MATLAB (R2016a) in Microsoft Excel, enter this text at the beginning of the VBA macro:

MLProgramId "9.0"

Run the macro by clicking Run Macro button. For details about running macros, see Excel Help.

To check that the preference is set, open the Preferences dialog box. The MATLAB program id box
contains 9.0. For details about the Preferences dialog box, see “Setting Spreadsheet Link
Preferences” on page 1-10.

Start MATLAB.
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For troubleshooting, see “Startup Errors” on page 3-11.

Input Arguments
version — MATLAB version
string

MATLAB version, specified as a string to indicate which MATLAB version to open when multiple
versions are installed on the computer.

The Windows registry defines the MATLAB version number under ...\Mathworks\MATLAB. For
example, MATLAB R2016a corresponds to version 9.0 in the registry.
Example: "9.0"

Tips
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLAutoStart | MLOpen

Topics
“Setting Spreadsheet Link Preferences” on page 1-10
“Startup Errors” on page 3-11

Introduced in R2016b
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MLClose
Stop MATLAB

Syntax
= MLClose()
MLClose
out = MLClose()

Description
= MLClose() ends the MATLAB process, deletes all variables from the MATLAB workspace, and tells
the Microsoft Excel software that the MATLAB software is no longer running. Use this syntax when
working directly in a worksheet.

MLClose ends the MATLAB process, deletes all variables from the MATLAB workspace, and tells the
Microsoft Excel software that the MATLAB software is no longer running. Use this syntax in a VBA
macro.

out = MLClose() lets you catch errors when executing MLClose in a VBA macro. If MLClose fails,
then out is a string containing error code. Otherwise, out is 0.

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

End the MATLAB Session

End the MATLAB session from a worksheet:

MLClose()

Tips
• If you use MLClose when no MATLAB process is running, nothing happens.
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLAutoStart | MLOpen

Topics
“Stop Spreadsheet Link and MATLAB” on page 1-13
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Introduced before R2006a
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MLDeleteMatrix
Delete MATLAB matrix

Syntax
= MLDeleteMatrix(var_name)
MLDeleteMatrix var_name
out = MLDeleteMatrix(var_name)

Description
= MLDeleteMatrix(var_name) deletes the named matrix from the MATLAB Workspace. Use this
syntax when working directly in a worksheet.

MLDeleteMatrix var_name deletes the named matrix from the MATLAB Workspace. Use this
syntax in a VBA macro.

out = MLDeleteMatrix(var_name) lets you find errors when executing MLDeleteMatrix in a
VBA macro. If MLDeleteMatrix fails, then out is a string containing an error code. Otherwise, out
is 0.

Examples

Delete MATLAB Matrix

Delete a matrix in the MATLAB Workspace using the MLDeleteMatrix function in an Excel
worksheet.

Create a 2-by-2 MATLAB matrix A.

A = [2 3; 4 6];

Open Excel and make sure cell A1 is selected in the worksheet. Delete the matrix A using the
MLDeleteMatrix function. Enter this text in the cell and press Enter.

= MLDeleteMatrix("A")

The MLDeleteMatrix function deletes the matrix from the MATLAB Workspace.

Delete MATLAB Matrix Using VBA Macro

Delete a matrix in the MATLAB Workspace using the MLDeleteMatrix function in a VBA macro.

Create a 2-by-2 MATLAB matrix A.

A = [2 3; 4 6];

On the Developer tab in Excel, click Visual Basic in the Code group. The Visual Basic Editor
window opens.
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Select Insert > Module to insert a new module. In the Module1 window, enter this VBA code
containing a macro named DeleteMatrix.

Sub DeleteMatrix()
    MLDeleteMatrix "A"
End Sub

The DeleteMatrix macro uses the MLDeleteMatrix function to delete the matrix A from the
MATLAB Workspace.

For details about working with modules, see Excel Help.

Run the macro by clicking Run Sub/UserForm button on the VBA toolbar. For details about running
macros, see Excel Help.

The MLDeleteMatrix function deletes the matrix from the MATLAB Workspace.

Input Arguments
var_name — Name of MATLAB matrix
string

Name of the MATLAB matrix to delete, specified as a string.

var_name in quotes directly specifies the matrix name. var_name without quotes specifies a
worksheet cell address (or range name) that contains the matrix name.
Example: "A"

Tips
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLAppendMatrix | MLGetMatrix | MLPutMatrix

Introduced before R2006a
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MLEvalString
Evaluate MATLAB command in MATLAB

Syntax
= MLEvalString(command)

MLEvalString command
err = MLEvalString(command)

Description
= MLEvalString(command) specifies the MATLAB command for evaluation in the MATLAB
workspace. Use this syntax when working in a worksheet cell.

MLEvalString command works in a VBA macro.

err = MLEvalString(command) returns the execution status when executing MLEvalString in a
VBA macro.

Examples

Create Diagonal Matrix in Worksheet Cells

Enter the variable a into cell A1. Enter the numbers 1 through 5 into the range of cells from B1
through F1.

Assign the range of cells to variable a in MATLAB using MLPutMatrix. Enter this text in cell A3.

=MLPutMatrix(A1,B1:F1)

Use diag to create a matrix b, containing a diagonal using the five numbers in variable a. Enter this
text in cell A5.

=MLEvalString("b = diag(a);")
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Retrieve matrix b from MATLAB into Excel cell A9. Enter this text in cell A7.

=MLGetMatrix("b","A9")

The matrix with the diagonal appears in cells A9 through E13.

Create Diagonal Matrix in VBA Macro

Enter the variable a into cell A1. Enter the numbers 1 through 5 into the range of cells from B1
through F1.

Click the Developer tab in Microsoft Excel, and then click Visual Basic. The Visual Basic Editor
window opens.

Insert a new module and enter this VBA code into the Code section of the window. This sample code
assumes a macro named Diagonal. For details on working with modules, see Excel Help.

Sub Diagonal()

    MLPutMatrix "a", Range("B1:F1")
    MLEvalString "b = diag(a);"
    MLGetMatrix "b", "A3"
    MatlabRequest

End Sub

Run the macro by clicking Run Sub/UserForm (F5). The diagonal matrix appears in cells A3
through E7. For details on running macros, see Excel Help.
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Return Error for Invalid Command

Enter the variable a into cell A1. Enter the numbers 1 through 5 into the range of cells from B1
through F1.

Click the Developer tab in Microsoft Excel, and then click Visual Basic. The Visual Basic Editor
window opens.

Insert a new module and enter this invalid VBA code into the Code section of the window. This sample
code assumes a macro named Diagonal. For details on working with modules, see Excel Help.

Sub Diagonal()

    Dim err As Variant

    MLPutMatrix "a", Range("B1:F1")
    err = MLEvalString("b = diag(2a);") 'Invalid code
    
    If err <> 0 Then
        MsgBox err
    End If

    MLGetMatrix "b", "A3"
    MatlabRequest

End Sub

Run the macro by clicking Run Sub/UserForm in the VBA toolbar. For details on running macros,
see Excel Help.

This Spreadsheet Link error displays: #COMMAND!. To display MATLAB errors, see
MLShowMatlabErrors.

Input Arguments
command — MATLAB command to evaluate
string

MATLAB command to evaluate, specified as a string. Enclose the string in double quotes. Or, enter
the string in a cell without quotes and enter the corresponding cell reference without quotes as the
input argument.
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Example: "sum"
Example: A1

Output Arguments
err — Execution status
string | number

Execution status, returned as a string or number. If MLEvalString fails, then err is a string
containing an error code or error message. Otherwise, the command executes successfully and err is
0.

By default when MLEvalString fails, err contains a standard Spreadsheet Link error, such as
#COMMAND. To return MATLAB errors, execute MLShowMatlabErrors.

Tips
• The specified action alters only the MATLAB workspace and has no effect on the Microsoft Excel

workspace.
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLGetMatrix | MLPutMatrix | MLShowMatlabErrors | diag

Topics
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Model Data Using Regression and Curve Fitting” on page 2-2
“Interpolate Thermodynamic Data” on page 2-8
“Price Stock Options Using Binomial Model” on page 2-11
“Executing Spreadsheet Link Functions” on page 1-31
“Worksheet Cell Errors” on page 3-2
“Microsoft Excel Errors” on page 3-5

Introduced before R2006a
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MLGetFigure
Import current MATLAB figure into Microsoft Excel worksheet

Syntax
= MLGetFigure(width, height)
MLGetFigure width, height
out = MLGetFigure(width,height)

Description
= MLGetFigure(width, height) imports the current MATLAB figure into an Excel worksheet,
placing the top-left corner of the figure in the current worksheet cell. Specify the normalized width
and height of the figure in Excel. Use this syntax when working directly in a worksheet.

MLGetFigure width, height imports the current MATLAB figure into an Excel worksheet,
placing the top-left corner of the figure in the current worksheet cell. Use this syntax in a VBA macro.

out = MLGetFigure(width,height) lets you find errors when executing MLGetFigure in a VBA
macro. If MLGetFigure fails, then out is a string containing an error code. Otherwise, out is 0.

Examples

Import Current MATLAB Figure into Excel

After you create a figure in MATLAB, import the figure into an Excel worksheet.

Note If you use Excel 2007 or 2010, the width and height of the imported figure will be a quarter of
the size of the original figure.

Create a wireframe mesh in MATLAB using the peaks and surf functions. The figure window
displays a wireframe mesh.

z = peaks(25);
surf(z)
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Open Excel and make sure cell A1 is selected in the worksheet. Import the current figure into the
worksheet using the MLGetFigure function. Enter this text in the cell and press Enter.

= MLGetFigure(.8, .8)

The MLGetFigure function imports the current figure into the worksheet, placing the top-left corner
of the figure in the selected cell.
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Import Current Figure Using VBA Macro

After you create a figure in MATLAB, import the figure into an Excel worksheet using a VBA macro.

Create a wireframe mesh in MATLAB using the peaks and surf functions. The figure window
displays a wireframe mesh.

z = peaks(25);
surf(z)
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On the Developer tab in Excel, click Visual Basic in the Code group. The Visual Basic Editor
window opens.

Select Insert > Module to insert a new module. In the Module1 window, enter this VBA code
containing a macro named MyFigure.

Sub MyFigure()
    MLGetFigure 0.8, 0.8
    MatlabRequest
End Sub

The MyFigure macro uses the MLGetFigure function to import the current figure into the
worksheet. MatlabRequest initializes internal Spreadsheet Link variables and enables
MLGetFigure to function in a subroutine.

For details about working with modules, see Excel Help.

Select cell A1 for the position of the figure. Run the macro by clicking Run Sub/UserForm button on
the VBA toolbar. For details about running macros, see Excel Help.
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The MLGetFigure function imports the current figure into the worksheet, placing the top-left corner
of the figure in the selected cell.

Input Arguments
width — Width
real number

Width (in normalized units) of the MATLAB figure when imported into an Excel worksheet, specified
as a real number.
Example: 0.5

height — Height
real number

Height (in normalized units) of the MATLAB figure when imported into an Excel worksheet, specified
as a real number.
Example: 0.5

Tips
• If you use Microsoft Excel 2007 or 2010, MLGetFigure scales the imported figure by the product

of width and height along both dimensions.
• If worksheet calculation mode is automatic, the software executes MLGetFigure when you enter

the formula in a cell. If worksheet calculation mode is manual, enter the MLGetFigure function in
a cell, then press F9 to execute it. Note that pressing F9 can also execute other worksheet
functions and generate unpredictable results.

• If you use MLGetFigure in a macro subroutine, enter MatlabRequest on the line after
MLGetFigure. The execution of MatlabRequest initializes internal Spreadsheet Link variables
and enables MLGetFigure to function in a subroutine. Do not include MatlabRequest in a macro
function unless the function is called from a subroutine.
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• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLGetMatrix | MLGetVar

Introduced in R2006b
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MLGetMatrix
Write contents of MATLAB matrix to Microsoft Excel worksheet

Syntax
= MLGetMatrix(var_name,edat)
MLGetMatrix var_name, edat
out = MLGetMatrix(var_name,edat)

Description
= MLGetMatrix(var_name,edat) writes the contents of MATLAB matrix var_name in the Excel
worksheet, beginning in the upper-left cell specified by edat. Use this syntax when working directly
in a worksheet.

MLGetMatrix var_name, edat writes the contents of MATLAB matrix var_name in the Excel
worksheet, beginning in the upper-left cell specified by edat. Use this syntax in a VBA macro.

out = MLGetMatrix(var_name,edat) lets you catch errors when executing MLGetMatrix in a
VBA macro. If MLGetMatrix fails, then out is a string containing error code. Otherwise, out is 0.

Input Arguments
var_name

Name of MATLAB matrix to access.

var_name in quotes directly specifies the matrix name. var_name without quotes specifies a
worksheet cell address (or range name) that contains the matrix name. Do not use the MATLAB
variable ans as var_name.

edat

Worksheet location where the function writes the contents of var_name.

edat in quotes directly specifies the location. edat without quotes specifies a worksheet cell address
(or range name) that contains a reference to the location. In both cases, edat must be a cell address
or a range name.

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples
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Specify the Matrix Name and Location Directly

Write the contents of the MATLAB matrix bonds starting in cell C10 of Sheet2. If bonds is a 4-by-3
matrix, fill cells C10..E13 with data:

MLGetMatrix("bonds", "Sheet2!C10")

Specify the Matrix Name and Location Indirectly

Access the MATLAB matrix named by the string in worksheet cell B12. Write the contents of the
matrix to the worksheet starting at the location named by the string in worksheet cell B13:

MLGetMatrix(B12, B13)

Use MLGetMatrix in a VBA Macro

Write the contents of MATLAB matrix A to the worksheet, starting at the cell named by RangeA:

Sub Get_RangeA()
MLGetMatrix "A", "RangeA"
MatlabRequest
End Sub

Use the Address Property of the Range Object to Specify Location

In a macro, use the Address property of the range object returned by the VBA Cells function to
specify where to write the data:

Sub Get_Variable()
MLGetMatrix "X", Cells(3, 2).Address
MatlabRequest
End Sub

Catch Errors in a VBA Macro

Use this function to get the variable A from MATLAB and to test if the command succeeded:

Sub myfun()
    Dim out As Variant
    
    out = MLGetMatrix("A", "A1")
    
    If out <> 0 Then
        MsgBox out
    End If
    MatlabRequest
End Sub
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If MLGetMatrix fails, myfun displays a message box with the error code.

Tips
• If data exists in the specified worksheet cells, it is overwritten.
• If the dimensions of the MATLAB matrix are larger than that of the specified cells, the data
overflows into additional rows and columns.

• edat must not include the cell that contains the MLGetMatrix function. In other words, be
careful not to overwrite the function itself. Also make sure there is enough room in the worksheet
to write the matrix contents. If there is insufficient room, the function generates a fatal error.

• MLGetMatrix function does not automatically adjust cell addresses. If edat is an explicit cell
address, edit it to correct the address when you do either of the following:

• Insert or delete rows or columns.
• Move or copy the function to another cell.

• If worksheet calculation mode is automatic, MLGetMatrix executes when you enter the formula
in a cell. If worksheet calculation mode is manual, enter the MLGetMatrix function in a cell, and
then press F9 to execute it. However, pressing F9 in this situation may also execute other
worksheet functions again and generate unpredictable results.

• If you use MLGetMatrix in a macro subroutine, enter MatlabRequest on the line after the
MLGetMatrix. MatlabRequest initializes internal Spreadsheet Link variables and enables
MLGetMatrix to function in a subroutine. Do not include MatlabRequest in a macro function
unless the function is called from a subroutine.

• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLAppendMatrix | MLPutMatrix | MLPutRanges

Topics
“Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
“Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
“Executing Spreadsheet Link Functions” on page 1-31

Introduced before R2006a

4 Functions

4-30



MLGetVar
Write contents of MATLAB matrix in Microsoft Excel VBA variable

Syntax
MLGetVar ML_var_name, VBA_var_name

Description
MLGetVar ML_var_name, VBA_var_name writes the contents of MATLAB matrix ML_var_name in
the Excel Visual Basic for Applications (VBA) variable VBA_var_name. Creates VBA_var_name if it
does not exist. Replaces existing data in VBA_var_name.

Input Arguments
ML_var_name

Name of MATLAB matrix to access.

ML_var_name in quotes directly specifies the matrix name. ML_var_name without quotes specifies a
VBA variable that contains the matrix name as a string. Do not use the MATLAB variable ans as
ML_var_name. If defined, ML_var_name must be of type VARIANT. Any other type will give a "TYPE
MISMATCH" error.

VBA_var_name

Name of VBA variable where the function writes the contents of ML_var_name.

Use VBA_var_name without quotes.

Examples

Write the Contents of a MATLAB Matrix into a VBA Variable

Write the contents of the MATLAB matrix J into the VBA variable DataJ:

Sub Fetch()
MLGetVar "J", DataJ
End Sub

See Also
MLPutVar

Topics
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Executing Spreadsheet Link Functions” on page 1-31
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Introduced before R2006a
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MLMissingDataAsNaN
Set empty cells to NaN or 0

Syntax
= MLMissingDataAsNaN(flag)
MLMissingDataAsNaN flag
out = MLMissingDataAsNaN(flag)

Description
= MLMissingDataAsNaN(flag) sets empty cells to NaN or 0. When the Spreadsheet Link software
is installed, the default is "no", so empty cells are handled as 0s. If you change the value of
MLMissingDataAsNaN to "yes", the change remains in effect the next time a Microsoft Excel
session starts. Use this syntax when working directly in a worksheet.

MLMissingDataAsNaN flag sets empty cells to NaN or 0. Use this syntax in a VBA macro.

out = MLMissingDataAsNaN(flag) lets you catch errors when executing MLMissingDataAsNaN
in a VBA macro. If MLMissingDataAsNaN fails, then out is a string containing error code.
Otherwise, out is 0.

Input Arguments
flag

Either "yes" or "no".

Specify "yes" to set empty cells to use NaNs. Specify "no" to set empty cells to use 0s.

Default: "no"

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

Set Empty Cells to Use 0s

Cancel the use of the value NaN for empty cells:

 MLMissingDataAsNaN

4-33



=MLMissingDataAsNaN("no")

Tips
• A string in an Excel range always forces cell array output and empty cells as NaNs.
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLPutMatrix

Introduced in R2007a
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MLOpen
Start MATLAB

Syntax
= MLOpen()
MLOpen
out = MLOpen()

Description
= MLOpen() starts MATLAB process. Use MLOpen to restart the MATLAB session after you have
stopped it with MLClose in a given Microsoft Excel session. Use this syntax when working directly in
a worksheet.

MLOpen starts MATLAB process. Use MLOpen to restart the MATLAB session after you have stopped it
with MLClose in a given Microsoft Excel session. Use this syntax in a VBA macro.

out = MLOpen() lets you catch errors when executing MLOpen in a VBA macro. If MLOpen fails,
then out is a string containing error code. Otherwise, out is 0.

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

Start a MATLAB Session

Start a MATLAB session from a worksheet:

MLOpen()

Tips
• If a MATLAB process has already started, subsequent calls to MLOpen do nothing.
• To start a MATLAB session and initialize the Spreadsheet Link software, use matlabinit rather

than MLOpen.
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLClose | matlabinit
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Introduced before R2006a
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MLPutMatrix
Create or overwrite MATLAB matrix with data from Microsoft Excel worksheet

Syntax
= MLPutMatrix(var_name, mdat)
MLPutMatrix var_name, mdat
out = MLPutMatrix(var_name,mdat)

Description
= MLPutMatrix(var_name, mdat) creates or overwrites the matrix var_name in the MATLAB
Workspace with the data specified in mdat. The function MLPutMatrix creates var_name if it does
not exist. Use this syntax when working directly in a worksheet.

MLPutMatrix var_name, mdat creates or overwrites the matrix var_name in the MATLAB
Workspace with the data specified in mdat. Use this syntax in a VBA macro.

out = MLPutMatrix(var_name,mdat) lets you find errors when executing MLPutMatrix in a
VBA macro. If MLPutMatrix fails, then out is a string containing an error code. Otherwise, out is 0.

Examples

Create MATLAB Matrix

Create a matrix in the MATLAB Workspace using the MLPutMatrix function in an Excel worksheet.

Enter the values 1 through 5 in cells A1 through E1.

Define the name testData for the range of cells A1 through E1. For instructions on defining names,
see Excel Help.

The range name testData appears in the Name Box when the range is selected.
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Execute the MLPutMatrix function in cell A2. Use A as the name of the matrix to create. Specify the
range name testData as the data to include in the matrix.

= MLPutMatrix("A", testData)

After you press Enter, Excel creates the matrix in the MATLAB Workspace. The matrix contains the
data included in the testData cell range.

Create MATLAB Matrix Using VBA Macro

Create a matrix in the MATLAB Workspace using the MLPutMatrix function in a VBA macro.

Enter the values 1 through 5 in cells A1 through E1.

Define the name testData for the range of cells A1 through E1. For instructions on defining names,
see Excel Help.

The range name testData appears in the Name Box when the range is selected.

On the Developer tab in Excel, click Visual Basic in the Code group. The Visual Basic Editor
window opens.

Select Insert > Module to insert a new module. In the Module1 window, enter this VBA code
containing a macro named PutMatrix.

Sub PutMatrix()
    MLPutMatrix "A", testData
End Sub

The PutMatrix macro uses the MLPutMatrix function to create the matrix A in the MATLAB
Workspace using the data in the cell range testData.

For details about working with modules, see Excel Help.

Select any worksheet cell. Run the macro by clicking Run Sub/UserForm button on the VBA toolbar.
For details about running macros, see Excel Help.
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The MLPutMatrix function creates the matrix in the MATLAB Workspace.

Input Arguments
var_name — Name of MATLAB matrix
string

Name of the MATLAB matrix to create or overwrite, specified as a string.

var_name in quotes directly specifies the matrix name. var_name without quotes specifies a
worksheet cell address (or range name) that contains the matrix name.
Example: "A"

mdat — Location of data
string

Location of the data to copy into var_name, specified as a string.

mdat must be a worksheet cell address or range name. Do not enclose the location in quotes.
Example: testData
Example: A1

Tips
• If var_name exists, the MLPutMatrix function replaces its contents with the contents of mdat.
• Empty numeric data cells in mdat become numeric zeros in the MATLAB matrix identified by

var_name.
• If any element of mdat contains string data, mdat becomes a MATLAB cell array. Empty string

elements in mdat become NaNs in the MATLAB cell array.
• When using MLPutMatrix in a subroutine, indicate the source of the worksheet data using the

Microsoft Excel macro Range. For example:

Sub test()
  MLPutMatrix "a", Range("A1:A3") 
End Sub 

If you have a named range in your worksheet, you can specify the name instead of the range. For
example:

Sub test() 
  MLPutMatrix "a", Range("temp") 
End Sub

• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLAppendMatrix | MLGetMatrix | MLPutRanges

Topics
“Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
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“Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
“Executing Spreadsheet Link Functions” on page 1-31

Introduced before R2006a
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MLPutRanges
Send data in Microsoft Excel named ranges to MATLAB

Syntax
= MLPutRanges()

MLPutRanges
out = MLPutRanges()

Description
= MLPutRanges() writes the named cell ranges in a Microsoft Excel worksheet into MATLAB
variables. The variables are named with the same name specified by the cell range name in Microsoft
Excel. To use this syntax, right-click in any Microsoft Excel cell, enter this syntax, and press Enter.

MLPutRanges writes the named cell ranges in a Microsoft Excel worksheet into MATLAB variables.
The variables are named with the same name specified by the cell range name in Microsoft Excel.
Use this syntax when working directly in a Microsoft Visual Basic macro.

out = MLPutRanges() returns the named cell ranges in a Microsoft Excel worksheet into MATLAB
variables. The variables are named with the same name specified by the cell range name in Microsoft
Excel. In this case, out specifies whether the MLPutRanges function executed successfully. Use this
syntax when working directly in a Microsoft Visual Basic macro.

Examples

Export Microsoft Excel Named Range to MATLAB in Microsoft Excel Cell

Enter the values 1 through 5 in cells A1 through E1.

Define a name for a range of cells from cell A1 through cell E1. For instructions about defining
names, see Excel Help and enter the search term: define and use names in formulas.

The name of the range of cells testData appears in the Name Box.
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To send data in the named range in the current worksheet to MATLAB, execute the function inside a
worksheet cell by entering this text.

= MLPutRanges()

After pressing Enter, Microsoft Excel exports the named range testData to the MATLAB variable
testData in the MATLAB workspace.
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Export Microsoft Excel Named Ranges to MATLAB in Microsoft Visual Basic Macro Without
Output

Call the function to send data in the named ranges in the current worksheet to MATLAB.

MLPutRanges

Export Microsoft Excel Named Ranges to MATLAB in Microsoft Visual Basic Macro with
Output

Call the function to send data in the named ranges in the current worksheet to MATLAB.

out = MLPutRanges()

out returns 0 if the function succeeded or a string with the corresponding error code if the function
failed.

Output Arguments
out — Status
0 | string

Status for execution of MLPutRanges, returned as 0 if the function succeeded, or a string containing
an error code.

Tips
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLGetMatrix | MLPutMatrix

Topics
“Create Diagonal Matrix Using Microsoft Excel Ribbon” on page 1-14
“Create Diagonal Matrix Using Microsoft Excel Context Menu” on page 1-16
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Find and Execute MATLAB Function Using MATLAB Function Wizard” on page 1-23
“Executing Spreadsheet Link Functions” on page 1-31

Introduced in R2013b
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MLPutVar
Create or overwrite MATLAB matrix with data from Microsoft Excel VBA variable

Syntax
MLPutVar ML_var_name, VBA_var_name
out = MLPutVar ML_var_name, VBA_var_name

Description
MLPutVar ML_var_name, VBA_var_name creates or overwrites matrix ML_var_name in MATLAB
workspace with data in VBA_var_name. Creates ML_var_name if it does not exist. If ML_var_name
exists, this function replaces the contents with data from VBA_var_name.

out = MLPutVar ML_var_name, VBA_var_name lets you catch errors when executing MLPutVar.
If MLPutVar fails, then out is a string containing error code. Otherwise, out is 0.

Input Arguments
ML_var_name

Name of MATLAB matrix to create or overwrite.

ML_var_name in quotes directly specifies the matrix name. ML_var_name without quotes specifies a
VBA variable that contains the matrix name as a string.

VBA_var_name

Name of VBA variable whose contents are written to ML_var_name.

Use VBA_var_name without quotes.

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

Create a MATLAB Matrix Using Data Stored in a VBA Variable

Create (or overwrite) the MATLAB matrix K with the data in the VBA variable DataK:
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Sub Put()
MLPutVar "K", DataK
End Sub

Tips
• Use MLPutVar only in a macro subroutine, not in a macro function or in a subroutine called by a

function.
• Empty numeric data cells within VBA_var_name become numeric zeros within the MATLAB

matrix identified by ML_var_name.
• If any element of VBA_var_name contains string data, VBA_var_name is exported as a MATLAB

cell array. Empty string elements within VBA_var_name become NaNs within the MATLAB cell
array.

• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLGetVar

Topics
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Executing Spreadsheet Link Functions” on page 1-31

Introduced before R2006a
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MLShowMatlabErrors
Return standard Spreadsheet Link errors or full MATLAB errors

Syntax
= MLShowMatlabErrors(flag)
MLShowMatlabErrors flag

Description
= MLShowMatlabErrors(flag) sets the error message type when executing MATLAB commands
using MLEvalString in Microsoft Excel. An error displays when MLEvalString fails. You can
display two different types of error messages. At any point, you can switch between displaying
Spreadsheet Link and MATLAB errors. Without this function, worksheet cells display only Excel error
messages. Use this syntax when working in a worksheet cell.

MLShowMatlabErrors flag works in a VBA macro.

Examples

Display Spreadsheet Link Errors in Worksheet Cell

This Spreadsheet Link code assumes MLEvalString returns MATLAB errors upon failure.

Enter this text in any worksheet cell to display MLEvalString failures as Spreadsheet Link errors.

=MLShowMatlabErrors("no")

Enter this invalid text in any worksheet cell.

=MLEvalString("sum(2+b);")

This Spreadsheet Link error appears in the calling cell.

#COMMAND!

Display MATLAB Errors in VBA Macro

This VBA code assumes MLEvalString returns Spreadsheet Link errors upon failure.

Enter this text at the beginning of a VBA macro to display MLEvalString failures as MATLAB errors.

MLShowMatlabErrors "yes"

Enter this invalid text in the VBA macro.

out = MLEvalString("sum(2+b);")
MsgBox (out)
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When running this macro, this MATLAB error appears in a dialog box: ??? Undefined function
or variable 'b'. For details on running macros, see Excel Help.

Input Arguments
flag — Error message indicator
"no" (default) | "yes"

Error message indicator, specified as "no" or "yes" to determine the type of error message
displayed when MLEvalString fails. To display the standard Spreadsheet Link errors, specify "no".
To display the full MATLAB errors, specify "yes".

Tips
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLEvalString

Topics
“Create Diagonal Matrix Using Worksheet Cells” on page 1-19
“Create Diagonal Matrix Using VBA Macro” on page 1-21
“Executing Spreadsheet Link Functions” on page 1-31
“Worksheet Cell Errors” on page 3-2
“Microsoft Excel Errors” on page 3-5

Introduced in R2006b
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MLStartDir
Specify MATLAB current working folder after startup

Syntax
= MLStartDir(path)
MLStartDir path
out = MLStartDir(path)

Description
= MLStartDir(path) sets the MATLAB working folder after startup. Use this syntax when working
directly in a worksheet.

MLStartDir path sets the MATLAB working folder after startup. Use this syntax in a VBA macro.

out = MLStartDir(path) lets you catch errors when executing MLStartDir in a VBA macro. If
MLStartDir fails, then out is a string containing error code. Otherwise, out is 0.

Input Arguments
path

Path to the new MATLAB working folder after startup.

Output Arguments
out

Execution status that contains 0 if the command succeeded. Otherwise, out contains a string with an
error code.

Examples

Specify MATLAB Working Folder

Set the MATLAB working folder to d:\work after start up in a worksheet cell.

=MLStartDir("d:\work")

Specify MATLAB Working Folder That Includes Spaces

If your folder path includes a space, embed the path in single quotation marks within double
quotation marks.

Set the MATLAB working folder to d:\my work in a VBA macro.
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MLStartDir "'d:\my work'"

Specify MATLAB Working Folder with Execution Status

Set the MATLAB working folder to d:\work after start up in a VBA macro. Return the execution
status out.

out = MLStartDir("d:\work")

Tips
• This function does not work like the standard Microsoft Windows Start In setting, because it does

not automatically run startup.m or matlabrc.m in the specified folder.
• The working folder changes only if you run MATLAB after you run this function. Running this

function while MATLAB is running does not change the working folder for the current session. In
this case, MATLAB uses the specified folder as the working folder when it is restarted.

• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a
reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLAutoStart

Introduced in R2006b
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MLUseCellArray
Toggle MLPutMatrix to use MATLAB cell arrays

Syntax
= MLUseCellArray(flag)
MLUseCellArray flag
out = MLUseCellArray(flag)

Description
= MLUseCellArray(flag) specifies whether MLPutMatrix must use cell arrays for transfer of
data (for example, dates). When the Spreadsheet Link software is installed, the default is "no". If you
change the value of MLUseCellArray to "yes", the change remains in effect the next time a
Microsoft Excel session starts. Use this syntax when working directly in a worksheet.

MLUseCellArray flag specifies whether MLPutMatrix must use cell arrays for transfer of data.
Use this syntax in a VBA macro.

out = MLUseCellArray(flag) lets you catch errors when executing MLUseCellArray in a VBA
macro. If MLUseCellArray fails, then out is a string containing error code. Otherwise, out is 0.

Input Arguments
flag

Either "yes" or "no".

Specify "yes" to automatically uses cell arrays for transfer of data structures. Specify "no" to stop
using cell arrays for transfer of data structures.

Default: "no"

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

Stop Using Cell Arrays When Transferring Data Structures

Cancel automatic use of cell arrays for easy transfer of data:
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MLUseCellArray("no")

Tips
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLPutMatrix

Introduced in R2007a
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MLUseFullDesktop
Specify whether to use full MATLAB desktop or Command Window

Syntax
= MLUseFullDesktop(flag)
MLUseFullDesktop flag
out = MLUseFullDesktop(flag)

Description
= MLUseFullDesktop(flag) sets the MATLAB session to start with the full desktop or Command
Window only. Use this syntax when working directly in a worksheet.

MLUseFullDesktop flag sets the MATLAB session to start with the full desktop or Command
Window only. Use this syntax in a VBA macro.

out = MLUseFullDesktop(flag) lets you catch errors when executing MLUseFullDesktop in a
VBA macro. If MLUseFullDesktop fails, then out is a string containing error code. Otherwise, out
is 0.

Input Arguments
flag

Either "yes" or "no".

Specify "yes" to start full MATLAB desktop. Specify "no" to start the Command Window only.

Default: "yes"

Output Arguments
out

0 if the command succeeded. Otherwise, a string containing error code.

Examples

Start Only the Command Window

Set the MATLAB session to start with the command window only:
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MLUseFullDesktop("no")

Tips
• To work with VBA code in Excel with Spreadsheet Link, you must enable Spreadsheet Link as a

reference in the Microsoft Visual Basic Editor. For details, see “Installation” on page 1-3.

See Also
MLClose | MLOpen | matlabinit

Introduced in R2006b
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